What has happened to CDS

Home Forums Technical Support / Bugs Copernic Desktop Search Desktop Search 4 What has happened to CDS

This topic contains 19 replies, has 12 voices, and was last updated by  Joe 5 years, 2 months ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
  • #3412


    Just installed the CDS 4 update. What a mistake that was…. again. I’ve been using CDS for 10-15 years. V2 was the best, v3 was ok and v4 is very poor, show that every release just gets worse. When I logged into the support page it said I had an update. Not knowing it would render my installed version useless, I thought I’d give CDS 4 one more look after it failed to meet v3 standards previously. Imagine my disappointment when it would not accept my serial #. I then knew I was screwed – sure enough my old version was gone. Ok, I’ll give v4 a try and maybe if who ever owns CDS now has gotten their act together I’d buy a new copy.

    First test: let do some email search. WHAT, wait it can’t find my email. Let me try this dropdown and select Today’s email – CRASH – CDS has to close… seriously?. Now reloaded from crash. Ok, let’s just select in the config. and select my email. What the heck, I see the Option for MS Outlook but it won’t let me select it. Well that’s messed up.I can’t select my email to be indexed.

    Second: What about files. Huh, this stupid software didn’t import my configuration from CDS 3. What, did you for get about your own previous versions that people own? What has happened to the once great Copernic? The config shows all file paths on my computer are excluded – kind dumb don’t you think. After all, this is a search engine. How am I suppose to use a trial version if everything is disabled. If all I can look at is the pretty colors just send me a damm picture. And the colors and icons are inferior to previously release. Fire your UI designer.

    Third: Now I’m really discouraged. CDS used to be the most important piece of software I owned. Absolutely one of the first pieces of software I’d put on my computer. Now its just a piece of donkey heap. Who ever took this over completely wasted a great piece of software. This means I’m forever stuck in CDS v2/v3 land. Ah the good ole days.

    Suggestion: Dump the guys working on this project and hire back however wrote v2. Last great release for CDS. I’m sure you’ve all worked hard but guys really missed the target. Ain’t no friggin way I’m going to give you money just to look at the ugly software interface. Especially when the reality is that I’d be likely uninstalling it anyway. WHAT A SHAME because I really need the solution that CDS could offer. Good search software is critical anymore in a heavily networked environment where I index over 1 million files and I can get 500-800 emails a week. CDS is the only way to really find things. What on earth are you thinking with this so-called Trial version. Come on, give me something to work with. You’re asking me to buy a car without test driving it – nuts.

    Last question: Are you a publicly traded company? because I want to short your stock.


    Lost another loyal customer



    I’ve reinstalled V3


    1. it’s easier to select file-type-filter

    2. the filemanager-context-menu has gone – it has many useful entries for working with files

    3. after 2 weeks I’ve a curios copernic-form-frame, only the left upper part is visible.

    4. I didn’t find any feature that would be a reason for staying on V4



    I can only echo the serious concerns expressed by others. Copernic Corporate Desktop almost always worked like a charm. It was indispensable. Now with the newest update here is what we get instead:

    Error occurred on 01/27/2014 20:04:45 UTC.


    Catastrophic failure (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))
    ”   at Interop.OpenIndexing.IIndexingKernel.Index_DeleteDocuments(String DeletionQuery, Boolean Asynchronous)
    at Copernic.DesktopSearch.Models.SearchPlatform.SearchPlatformEngine.RemoveFromIndex(String deletionQuery)
    at Copernic.DesktopSearch.Models.SearchPlatform.SearchPlatformEngine.RemoveFromIndexNonIndexedExtensions()
    at Copernic.DesktopSearch.Models.SearchPlatform.SearchPlatformEngine.ReloadExtensionsConfig()
    at Copernic.DesktopSearch.Models.SystemInitializer.InitPlugins(App app)
    at Copernic.DesktopSearch.Models.SystemInitializer.Initialize()
    at Copernic.DesktopSearch.ViewModels.MainWindowViewModel.set_CurrentMainView(Object value)
    at Copernic.DesktopSearch.ViewModels.MainWindowViewModel..ctor(CdsContext context, TaskbarIcon trayIcon)
    at Copernic.DesktopSearch.Views.MainWindow..ctor()
    at Copernic.DesktopSearch.App.PerformPostStartupActions()



    I have a client that has the same issue as you folks. The also seems to be ABSOLUTELY NO CARE on COPERNIC SUPPORT’S end. I am going on TWO WEEKS with hearing NOTHING from them.

    What a horribly run “support” group. I can only imagine how many licences they have sold and do not support.

    I wish I would have known my clients were looking to purchase this “application” beforehand. I would have done some investigation for them prior to them purchasing and moved them away from Copernic. Email Support – minimum of 48hr response. More like “a minimum of multiple weeks IF WE WANT TO RESPOND AT ALL”



    No kidding on the error and support issue! I recieved an email asking that I reinstall ver. 3 and then ver. 4. when it did not work I informed them. Heard nothing from support for some time now. Also, the really funny thing here is, after reinstalling as instructed I needed to get my license number back. Used the website to obtain the license number and would’nt you know it…radio silence. Never heard back from anyone. Now I am looking at X1 desktop search, and others. Sure wish I could get my money back.


    Copernic Support

    Hi folks,

    We’re sorry you’ve been experiencing a bad support on your end with the latest issues. Our development team continues to work and fix many bugs and improve features. There is an average of 1 new release each month and we do care about every support ticket submitted. Unfortunately, right now we’ve receiving a higher amount of request than what we can proceed in a legitimate amount of time. In some cases with specific errors, response time can take a few extra days to take care.

    We’re sorry about this situation and we’re trying to resolve this as soon as possible.



    It is funny – the apologies from Tech Support came right after the release of a new version (4.0.5) that crashed on me right away, and I cannot roll back to 4.0.4.

    Can you release a 4.0.4 version that does not check if 4.0.5 was installed? Will it be possible to keep the index data?


    Copernic Support

    Hi Alexei,

    This issue tend to persist with some users installation, so with every update, there’s old files from a previous install that seems to cause problems, and the setup is ending prematurely, leaving the user stuck without a working version.

    In this situation, there is a drastic solution but that may be the best one to make sure that it doesn’t come back in the future.

    You may want to try these steps: 

    1. Backup your current index:

    • (On windows xp) open folder C:\Documents and Settings\**your username**\Local Settings\Application Data\Copernic\DesktopSearch4
    • (On windows vista/7/8) open folder C:\Users\**your username**\AppData\Local\Copernic\DesktopSearch4
    • Take a backup of the “index” folder 
    • Take a backup of the “config.xml” file

    2. Remove Copernic Desktop Search 4 completely with windows control panel.
    3. Once uninstalled, make sure there is no remaining files from Copernic Desktop Search 4 in the above folder, or in C:\Program Files\.

    4. Try to reinstall CDS 4 with the following link: http://go.copernic.com/?dest=cds4installer
    5. If the install complete successfully, simply put back your backup index at the same location (but make sure CDS is closed when you do it)

    If the install do not complete properly, it may means the problem is deeper in your registry/conversion from CDS 3 to 4, so I suggest the following:

    6. Repeat steps 2-4 to make sure you uninstall CDS 4 completely once again

    7. Install Copernic Desktop Search 3 Professional. Use the following link:
    8. Let CDS 3 start for the first time (you can enter a serial from CDS3 if you have one, or simply start a trial period, it doesn’t really matter), then close it immediately (by using the right click on the tray icon)
    9. Download and install Copernic Desktop Search 4 without removing CDS3 Professional. Use the following link:
    (The installation of CDS4 will remove CDS3 automatically)

    We noticed that on some computer there was traces left of an old CDS3 installation when CDS4 cannot be installed or cannot be launch properly. This trick seems to have resolved the situation with a lot of concerned users.

    Always keep in mind to submit these kinds of issues to support directly since it’s too hard to answer a global procedure on the forum for everybody since almost all configurations are different.



    In the AppData director, there was a 3.0 folder. Uninstalled utilzing Revo, reinstalled Copernic. replaced the old folder and file, entered the old key, and it is now working again.

    Frustrating!!!! I do not have time for this!!!!!!!!!!!!! Like mentioned above, version 2 and 3 worked!



    What should I do with the directory mentioned in Step 1 if my index is in a different directory (i.e., not in the default one)?



    To Tech Support:

    Steps 1-5 did not work. I give up on CDS: too many disappointments recently.


    Copernic Support

    @smilesby : We’re glad you finally managed to install it properly.

    @alexei: If your index is not in the default folder, you can still take a backup of it, but you will have to restore it in the default folder once the software is reinstalled, then once it’s back working, you can move your index back to your custom folder.

    If step 1-5 did not work, you should really consider going through step 6-9. Unfortunately this is a technical issue that could happen with other softwares too. We’re sorry to hear you want to give up on CDS.



    @Copernic Support: please disregard my requests – I have just lost my index data (2 weeks of running CDS in the unrestricted mode!), and I am not building it again. I already had to re-build the index data when I installed 4.0.4.

    I will not use the product which destroys its data with each minor maintenance release.




    @Copernic Support wrote: If your index is not in the default folder, you can still take a backup of it, but you will have to restore it in the default folder once the software is reinstalled, then once it’s back working, you can move your index back to your custom folder.

    In case you did not know – the new version 4.0.5 has a different index folder structure: Index_folder->Index->Index->MainChunk





    Don’t install Copernic V4, just stay withe V3 that was working so well. V4 is slow, takes all computer resources, and, in most cases, is no longer able to index outlook.



    I agree.  Just got my refund for ver 4 (would crash).  Going back to 3.  Copernic, do you care that you’re losing customers?



    Yet another disappointed long-term-customer!

    I just (a few days ago – see http://www.copernic.com/blog/index.php/forums/topic/outlook-pst-archives-on-network-drives/ ) was informed by Copernic Support that they simply do not intend to solve (or at least kind of circumvent) an imho major problem.

    “Upgrading all our file extractors” seems to be more important to them than being able to keep “once indexed” network located email files alive.

    I am a mobile worker, and don’t see why I should carry around something like 15GB of archived emails on my laptop every day (just imagine, the laptop could get lost) – however I need to be able every now and then to find a specific email in this haystack.

    CDS “was” the right thing for me to address this requirement – but it looks like CDS is no longer able to do this…

    Will have to look for an alternative!
    Anybody has any suggestions?



    To it-solutions

    I used Copernic 3.x for a few years and was quite happy with it until a terrible upgrade to 4.x, after which I switched to X1 Search which also had some problems. I think their common problem is the attempt to update in real-time. Both are very sensitive to various application and system shutdown scenarios.

    Finally, I started using dtSearch which is more expensive, but is very robust, although it does not have fancy GUI features of the above mentioned applications. dtSearch was designed for the advanced users – you have to know what you are doing, but otherwise it is a great tool!



    Thanks Alexei,
    I will investigate this. However I still kind of hope the COPERNIC team will eventually realise they are walking a dangerous path with their product… and start acting accordingly…



    • This reply was modified 5 years, 2 months ago by  Joe.
Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.